首页 > 考试 > 认证考核 > 思科认证 > CCNA >

Cisco3640路由器设置

2009-02-28

一、 设置路由器管理信息 1、 用扁平控制线接上9孔接头,连接CONSOLE到终端或PC串口,设置终端或直接连至串口的超级终端的参数:BAND率9600,无奇偶校验,8位数据位,1位停止位. 2、 路由器上电,终端屏幕会显示上电

一、 设置路由器管理信息
1、 用扁平控制线接上9孔接头,连接CONSOLE到终端或PC串口,设置终端或直接连至串口的超级终端的参数:BAND率9600,无奇偶校验,8位数据位,1位停止位.
2、 路由器上电,终端屏幕会显示上电过程。
3、 进入特权模式设置口令
line vty 0 4
password bc123
exit
enable secret bc123fzq123
exit
4、 在特权模式设置路由器信息:
hostname bc3640
ip domain-list jzl.cq
ip domain-list jz2.cq
ip domain-name jzl.cq
ip name-sever 10.54.34.1
5、 进入全局模式,配置以太网地址
configure timinal
interface fastethernet 0/0
ip address 192.168.254.254 255.255.255.0
no shutdown
exit
interface fastethernet 1/0
ip address 10.154.34.253 255.255.255.252
noshut down
exit
设置IP路由功能开放
ip routing
设置拨入客户名和口令
username user1 password 123
设置拨号组参数,为拨号客户指定ip地址
line 65 72
autoselect ppp
modem inout
transport inputall
exit
interface group-async1
ip unnumbered fastethernet 1/0
encapsulation ppp
dialer in band
dialer map ip 10.154.34.247 name user 1
async default routing
anync mode interactive
peer default ip address pool default
ppp authentication chap pap
group-ranger 65 72 ;路由器远程拨入端口
设置内部ospf路由协议、静态路由
access-list 77 permit 10.154.34.0 0.0.1.255
router ospf 110
redistribute connected subnets
redistribute static subnets
passive-interface fastethernet 0/0
network 10.154.34.0 0.0.255 area 0
network 10.154.35.0 0.0.0.255 area 0
distribute-list 77 out
exit

ip default-gateway 10.154.34.254
Ip router 0.0.0.0 0.0.0.0 10.154.34.254
Ip router 10.0.0.0 255.0.0.0 10.154.34.254
Ip router 192.168.0.0 255.255.0.0 192.168.254.1
设置NAT转换
access-list 99 deny 192.168.3.1
access-list 99 permit 192.168.3.0 0.0.0.255
access-list 99 permit 192.168.0.0 0.0.255.255
ip nat pool netdyn 10.154.35.1 10.154.35.126 netmask 255.255.255.0
ip nat inside source list 99 pool netdyn overload
ip nat inside source static 192.168.3.1 10.154.35.1
interface fastethernet1/0
ip nat outside
exit
interface group-async1
ip nat outside
exit
interface fastethernet 0/0
ip nat insider
exit
write memory
二、 CISCO路由器广域网配置向导
1、 dial-on demand routing (ddr)是用公共电话网提供了网络连接。通常的,广域网大多数使用专线连接的,路由器连接到类似MODEM OR ISDNTAS 的数据终端DCE设备上,他们支持同步V.25BITS协议,你可以用SCRIPTS AND DIALER命令设定拨号串。
DDR比较适用于用户对数率要求不高,偶尔有数据传输或只是在特定时候传输数据,比如银行每晚传送报表等等情况下。
当一个感兴趣的包到达路由器时,产生一个DDR请求,路由器发送呼叫建立信息给指定的串口的DCE设备,这个呼叫就把本地的和远程的设备连接起来,一旦没有数据传输,空闲时间开始记时,超过设置的记时时间,连接终止。DDR现在都用静态路由来传输数据,避免路由交换引起的DDR拨号。
和XNS可以通过DDR路由寻址,同步串口,异步串口和ISDN端口可以配置成到一个或多个目的地的DDR连接。
下面是一个典型的DDR连接:
在配置DDR过程中,我们可以把一个或几个物理端口配置成一个逻辑拨号接口,他可以是同步V.25方式,同步DYR启动拨号或异步CHATSCRIPT方式
在端口配置模式下:
在一个端口激活DIAL-ON-DEMAND ROUTING
命令:dialer in-band
指定一个端口为拨号访问组:dialer-group group-number
指定一个单一电话号码:dialer string dialer-string
断线前空前等待时间:dialer idle-time seconds
定义一个或多个目的电话号码表:
dialer map protocol net-hop-address dialer-string
限定传输的access-list表或特定协议:
dialer-list dialer-group list access-list-number或
dialer-list dialer-group protocol protocol name(permit/deny/list access-list-number)
具体配置:

interface serial 0
ip address 131.108.126.1 255.255.255.0
dialer in-band
dialer-group 1
!
dialer map ip 131.108.126.2 55551234
!
dialer idle-timeout 300
dialer backup example
A) 同步V.25bits方式
configuration for routerA:
interface serial 10:0
backup delay 0 10
backup interface serial 110
ip address 16.217.30.2 255.255.255.252
!
interface serial 110
ip address 16.30.16.81 255.255.255.25.0
encapsulation ppp
dialer in-band
dialer string 8292
dialer-group 1
pulse-time 1
!
dilar-list 1 protocol ip permit
B) 辅助口作拨号备份
configuration for routerA:
chat-script mydial “””atdt 8292” timeout 60 “connect”
!
interface serial 0
backup delay 0 0
backup interface async1
ip address 16.3.1.1 255.255.255.0
encapsulation ppp
!
interface async1
ip address 16.3.2.1 255.255.255.0
encapsulation ppp
keepalive 9
async default routing
async dynamic address
async dynamic routing
async mode dedicated
dialer string 8292
dialer-group 1
!
dialer-list 1 protocol ip permit
!
line aux 0
script dialer mydial
modeinout
transport output none
stopbits 1
flowcontrol hardware
speed 9600
subinterface example (frame realay)
configuration for routerA:
interface serial 0
encapsulation frame-relay
interface serial 0.1 multipoint
ip address 11.10.11.1 255.255.255.0
frame-relay interface-dlci 41
frame-relay interface-dlci42

configuration for routerC:
interface serial 0
encapsulation frame-relay
interface serial 0.1 point-point
ip address 11.10.16.2 255.255.255.0
frame-realy interface-dlci 46

configuration for routerB:

interface serial 0
encapsulation frame-relay
interface serial 0.1 multipoint
ip address 11.10.11.3 255.255.255.0
frame-relay interface-dlci 43
frame-relay interface-dlci 44
!
interface serial 0.2 point-point
ip address 11.10.13.1 255.255.255.0
frame-realy interface-dlci 48

frame relay switching example
configuration for routerA:
frame-relay switching
no ip address
frame-relay encapsulation
frame-relay route 163 tun0 43
frame-relay intf-type dce
!
interface serial0
ip address 131.108.100.1 255.255.255.0
!
interface tu 0
tunnel source serial 1
tunnel destintion 131.108.13.2

configuration for routerB:
frame-relay switching
!
interface serial 0
no Ip address
frame-relay encapsulation
frame-relay router 9 tun0 43
frame-relay interface-type dce
!
int tu 0
tunnel source serial 1
tunnel destination 131.108.100.1


channelized E1interface example
假设是7500系列路由器,E1接口(MIP板)在插槽4上面。
一个CHANNEL-GROUP 可对应多个时间槽,本例中SERIAL4/0:1有5*64的速率
configuration for router :
controller e1 0
framing no-crc4
chanel-group 0 timeslots1
channel-group 1 timeslots 2,7-9,20 speed 64
!
interface serial4/0:0
Ipaddress 16.217.30.2 255.255.255.252
Encapsulation ppp
!
interface serial 4/0:1
ip address 16.205030.5 255.255.255.252

X.25 EXAMPLE
在配置X.25 时,为减少路由交换引起的呼叫,通常用静态路由,而当一对多情况下,不在一个子网中用subinface 配置
configuration for router:
interface serial 0
ip address 131.108.100.1 255.255.255.0
encapsulation X.25
X.25 address 041673226839
x.25 htc 16
x.25 map ip 131.108.100.2 041675222222
int s 0.1
ip address 131.108.101.1 255.255.255.0
x.25 mapip 131.108.101.2 041674222222
!
ip router 131.108.100.0 255.255.255.0 131.108.100.2
ip router 131.108.101.0 255.255.255.0 131.108.101.2

相关文章
最新文章
热点推荐