首页 > 系统 > 其他 >

Ubuntu双显卡解决方案(Nvidia)

2014-02-26

系统版本 : Ubuntu12 04 硬件型号: IntelCorporation Core Processor Integrated Graphics Controller NVIDIACorporation GF108M [GeForce GT 425M] 简介: Nvidia使用的双显卡技术叫做SLI,

系统版本 :

Ubuntu12.04

硬件型号:

IntelCorporation Core Processor Integrated Graphics Controller
NVIDIACorporation GF108M [GeForce GT 425M]

简介:

Nvidia使用的双显卡技术叫做SLI,SLI的两款显卡地位并不是对等的,一块显卡作为主卡(Master),另一块则作为副卡(Slave)。其中主卡负责任务指派、渲染、后期合成、输出等运算和控制工作,而副卡只是接收来自主卡的任务进行相关处理,然后将结果传送回主卡。在SLI系统中有两部分不同的数据流向,一部分为主卡将任务指令通过PCB连接卡传送给副卡,副卡将渲染完毕的结果数据返回给主卡合成,另一部分为处理过程中从PCIExpress接口得到的原始数据。

这项技术在LINUX下没有实现,导致独立显卡在没有任务时也持续工作。

Bunblebeeproject提供了一种解决方案:

Bumblebeeaims to provide support forNVIDIAOptimus laptops for GNU/Linux distributions. Using Bumblebee, youcan use your NVIDIA card for rendering graphics which will bedisplayed using the Intel card. Bumblebee is officially supported byUbuntu in 13.10 Saucy or newer. However, all releases are supportedby theBumblebee Projectcommunity from Ubuntu version 12.04 up to 13.10.

1、跟新显卡ID

sudoupdate-pciids

lspci| grep -i vga

2、查看功耗

greprate /proc/acpi/battery/BAT0/state

3、安装bumblebee

BasicSetup

Youneed to open your terminaland enter the commands below.

Ifon 12.04.3, replace linux-headers-generic withlinux-headers-generic-lts-raring.

sudo add-apt-repository ppa:bumblebee/stable

Enablethe Universe and Multiverse repositories (for bumblebee and nvidiapackages respectively).

sudo apt-get update

InstallBumblebee using the default proprietary nvidia driver for 12.04 -13.04 :

sudo apt-get install bumblebee bumblebee-nvidia virtualgl linux-headers-generic

Andfor 13.10 :

sudo apt-get install bumblebee bumblebee-nvidia primus linux-headers-generic

Reboot

AdvancedSetups

Foradvanced users, if you do not want to use the proprietary nvidiadriver or 32-bit libraries (for example, if you are only interestedin power savings), you can do your custom installation.

Minimalsetup :sudo apt-get install --no-install-recommends bumblebee

Dependingon your needs, add to this line:

bumblebee-nvidia:proprietary nvidia driver support (if installed, become default overnouveau)

virtualgl:VirtualGL as backend

virtualgl-libs-ia32:32bit support for VirtualGL on 64bit system, necessary to run 32bitapp through optirun

primus:primus/primusrun as backend (virtualgl Stays default, you need torun optirun -b primus <app>)

primus-libs-ia32:32bit support for primus/primurun on 64bit system, necessary to run32bit app through optirun

4、测试

lspci| grep -i vga
grep rate /proc/acpi/battery/BAT0/state
glxgears
optirun glxgears
相关文章
最新文章
热点推荐