首页 > 网络 > 路由器 >

路由器设置之点到多点OSPF设置

2012-05-28

路由器设置之点到多点OSPF设置路由器子接口技术是把物理接口划分许多逻辑接口的技术,一个物理接口可以设置许多的逻辑的子接口,但每个子接口一样被独立的看待.路由器子接口技术有两中类型:点到点子接口和 多点子...

路由器子接口技术是把物理接口划分许多逻辑接口的技术,一个物理接口可以设置许多的逻辑的子接口,但每个子接口一样被独立的看待.
路由器子接口技术有两中类型:点到点子接口和 多点子接口.
那么我们建立了逻辑通道,只有在一个逻辑通道里面的两个节点可以通信,想要逻辑通道与逻辑通道互相通信我们怎么半?
这个时候就要用到我们的路由协议.至于用什么协议大家可以自己选择,要明白的一点就是路由协议使不同逻辑通道的节点可以通信,这样使我们整个帧中继所有的节点都可以通讯.和我们的VLAN有相同的地方,路由协议是实现了VLAN与VLAN之间的通讯.也可以这样理解,我们的路由协议是实现的物理通道或逻辑 通道的通讯.只要明白这写原理我们再多练习一下语法,你们我们的实验就应该没有什么问题.
点到多点子接口配置
R1>en
R1#conf t
R1(config)#interface loopback 100
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shut www.2cto.com
R1(config-if)#exit
R1(config)#interface s0
R1(config-if)#encap frame-relay 定义封装格式
R1(config-if)#no frame-relay inverse-arp 关闭帧中继逆向arp
R1(config-if)#interface serial 0.2 multipoint 进入s0的子接口定义为点到多点方式
R1(config-subif)#ip add 192.168.1.1 255.255.255.0 定义ip
R1(config-subif)#bandwidth 64
R1(config-subif)#frame map ip 192.168.1.2 102 broadcast 定义1个帧中继到ip地址的映射。
R1(config-subif)#frame map ip 192.168.1.3 103 broadcast
Router1(config-subif)#exit
R1(config-if)#exit
R1(config)#router ospf 101 配置ospf路由
R1(config-router)#net 10.0.0.0 0.0.0.255 area 0
R1(config-router)#net 192.168.1.0 0.0.0.255 area 0
R2>en
R2#conf t
R2(config)#interface loopback 100
R2(config-if)#ip address 10.1.2.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#interface s0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#encap frame-relay 定义封装格式
R2(config-if)#no frame-relay inverse-arp 关闭帧中继逆向arp
R2(config-if)#frame map ip 192.168.1.1 201 broadcast 定义1个帧中继到ip地址的映射。
R2(config-if)#bandwidth 64
R2(config-if)#frame-relay interface-dlci 201 设置DLCI的值
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#router ospf 101 配置ospf路由
R2(config-router)#net 10.1.2.0 0.0.0.255 area 0
R2(config-router)#net 192.168.1.0 0.0.0.255 area 0
R3>en
R3#conf t
R3(config)#interface loopback 100
R3(config-if)#ip address 10.1.3.1 255.255.255.0
R3(config-if)#no shut www.2cto.com
R3(config-if)#exit
R3(config)#interface s0
R3(config-if)#ip address 192.168.1.3 255.255.255.0
R3(config-if)#encap frame-relay 定义封装格式
R3(config-if)#no frame-relay inverse-arp 关闭帧中继逆向arp
R3(config-if)#frame map ip 192.168.1.1 301 broadcast 定义1个帧中继到ip地址的映射。
R3(config-if)#bandwidth 64
R3(config-if)#frame-relay interface-dlci 301 设置DLCI的值
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#router ospf 101 配置ospf路由
R3(config-router)#net 10.1.3.0 0.0.0.255 area 0
R3(config-router)#net 192.168.1.0 0.0.0.255 area 0
注:配置eigrp协议时VLSM技术要在r(config-router)#模式下用到no auto-summary(关闭eigrp协议的路由自动汇总功能)。只有这样才能看到A类B类网络个子网的信息。
本文来自于胖鲨鱼网
相关文章
最新文章
热点推荐