首页 > 网络 > 网络协议 >

配置负载分担VRRP

2012-03-20

配置负载分担VRRP应用环境负载分担是通过建立多个备份组的方式来分担网络流量,一台路由器可以属于多个备份组,其工作方式如下:路由器A作为备份组1的Master,同时又是备份组2的Backup路由器B作为备份组2的Maste...

配置负载分担VRRP
应用环境
负载分担是通过建立多个备份组的方式来分担网络流量,一台路由器可以属于多个备份组,其工作方式如下:

路由器A作为备份组1的Master,同时又是备份组2的Backup
路由器B作为备份组2的Master,同时又是备份组1的Backup
网络内部分主机使用备份组1作网关,部分主机使用备份组2作为网关
这样,既达到相互备份的目的,又可以分担网络流量。

说明

支持VRRP功能的接口包括Ethernet、Fast Ethernet、Gigabit Ethernet、VE(Virtual Ethernet)、Eth-Trunk、以太网子接口和VLANIF。

配置思路
在配置负载分担VRRP时,采用如下配置思路:

配置各路由器接口的网络层属性,使网络连通。
在路由器的指定接口下创建至少两个VRRP配置组。
指定接口在不同VRRP备份组中的优先级,使一台路由器既是一个备份组的Mater路由器,同时是其他备份组的Backup路由器。
配置注意事项
在配置负载分担VRRP时,需要准备以下数据:

VRRP备份组ID、虚拟IP地址
路由器在备份组中的优先级
配置实例
组网需求
如下图所示。

RouterA作为备份组1的Master,同时是备份组2的Backup。
RouterB作为备份组2的Master,同时是备份组1的Backup。
内部网络中的HostA使用备份组1作网关,HostC主机使用备份组2作为缺省网关,达到分担数据流而又相互备份的目的。
负载分担VRRP组网图



适用产品和版本
路由器可以使用任意一款NE系列产品,版本为VRP5.30及后续版本。

配置步骤
步骤1 配置设备之间的网络互连

# 配置主机HostA的缺省网关为备份组1的虚拟IP地址10.1.1.111,配置主机HostC的缺省网关为备份组2的虚拟IP地址10.1.1.112。

# 配置RouterA、RouterB、RouterC路由器之间运行OSPF。

步骤2 配置VRRP

# 在RouterA上配置接口GE2/0/0,创建备份组1,并配置RouterA在备份组1中的优先级为120(作为Master)。创建备份组2,并配置RouterA在备份组2中的优先级为缺省值100(作为Backup)。

<RouterA> system-view

[RouterA] interface gigabitethernet 2/0/0

[RouterA-GigabitEthernet2/0/0] ip address 10.1.1.1 24

[RouterA-GigabitEthernet2/0/0] vrrp vrid 1 virtual-ip 10.1.1.111

[RouterA-GigabitEthernet2/0/0] vrrp vrid 1 priority 120

[RouterA-GigabitEthernet2/0/0] vrrp vrid 2 virtual-ip 10.1.1.112

[RouterA-GigabitEthernet2/0/0] quit

# 在RouterB上配置接口GE2/0/0,创建备份组1,并配置RouterB在备份组1中的优先级为缺省值100(作为Backup)。创建备份组2,并配置RouterB在备份组2中的优先级为120(作为Master)。

<RouterB> system-view

[RouterB] interface gigabitethernet 2/0/0

[RouterB-GigabitEthernet2/0/0] ip address 10.1.1.2 24

[RouterB-GigabitEthernet2/0/0] vrrp vrid 1 virtual-ip 10.1.1.111

[RouterB-GigabitEthernet2/0/0] vrrp vrid 2 virtual-ip 10.1.1.112

[RouterB-GigabitEthernet2/0/0] vrrp vrid 2 priority 120

[RouterB-GigabitEthernet2/0/0] quit

验证结果
完成以上配置后,网络中HostA、HostC主机分别能够Ping通HostB。

在HostA和HostC上分别对HostB的地址进行tracert测试,可以看到HostA经过RouterA和RouterC到达HostB,而HostC经过RouterB和RouterC到达HostB。即,RouterA和RouterB对内部网络来的流量进行负载分担。

在RouterA上执行display vrrp命令,可以看到RouterA分别作为备份组1的Master和备份组2的Backup。

<RouterA> display vrrp

GigabitEthernet2/0/0 | Virtual Router 1

state : Master

Virtual IP : 10.1.1.111

PriorityRun : 120

PriorityConfig : 120

MasterPriority : 120

Preempt : YES Delay Time : 0

Timer : 1

Auth Type : NONE

Check TTL : YES

GigabitEthernet2/0/0 | Virtual Router 2

state : Backup

Virtual IP : 10.1.1.112

PriorityRun : 100

PriorityConfig : 100

MasterPriority : 120

Preempt : YES Delay Time : 0

Timer : 1

Auth Type : NONE

Check TTL : YES

配置文件
RouterA的配置文件
#

sysname RouterA

#

interface GigabitEthernet2/0/0

ip address 10.1.1.1 255.255.255.0

vrrp vrid 1 virtual-ip 10.1.1.111

vrrp vrid 1 priority 120

vrrp vrid 2 virtual-ip 10.1.1.112

#

interface Pos1/0/0

link-protocol ppp

ip address 192.168.1.1 255.255.255.0

#

ospf 1

area 0.0.0.0

network 192.168.1.0 0.0.0.255

network 10.1.1.0 0.0.0.255

#

return

RouterB的配置文件
#

sysname RouterB

#

interface GigabitEthernet2/0/0

ip address 10.1.1.2 255.255.255.0

vrrp vrid 1 virtual-ip 10.1.1.111

vrrp vrid 2 virtual-ip 10.1.1.112

vrrp vrid 2 priority 120

#

interface Pos1/0/0

link-protocol ppp

ip address 192.168.2.1 255.255.255.0

#

ospf 1

area 0.0.0.0

network 192.168.2.0 0.0.0.255

network 10.1.1.0 0.0.0.255

#

return

RouterC的配置文件
#

sysname RouterC

#

interface Ethernet3/0/0

ip address 20.1.1.1 255.255.255.0

#

interface Pos1/0/0

link-protocol ppp

clock master

ip address 192.168.1.2 255.255.255.0

#

interface Pos2/0/0

link-protocol ppp

clock master

ip address 192.168.2.2 255.255.255.0

#

ospf 1

area 0.0.0.0

network 192.168.1.0 0.0.0.255

network 192.168.2.0 0.0.0.255

network 20.1.1.0 0.0.0.255

#

return
相关文章
最新文章
热点推荐