首页 > 程序开发 > 软件开发 > Java >

myeclipse10.7安装git插件

2017-09-09

myeclipse10 7安装git插件。如果想把github上的一些开源项目导入到myeclipse中,一种方法是从github网站上将开源项目下载下来,另一种是使用myeclipse的egit插件直接从github网站上down下来,下面就说说安装egit插件的步骤(安装egit不成功的原因主要是下载的egit版本不

如果想把github上的一些开源项目导入到myeclipse中,一种方法是从github网站上将开源项目下载下来,另一种是使用myeclipse的egit插件直接从github网站上down下来,下面就说说安装egit插件的步骤(安装egit不成功的原因主要是下载的egit版本不适合当前使用的eclipse版本)。

通过上网搜索安装eclipse插件主要有以下三种方式:

第一种方式:

对于不同版本的eclipse和myeclipse可能有所不同,主要是有以下两种情况:

1.

EGit插件地址:https://download.eclipse.org/egit/updates

2.

\
\

使用第一种方式,好处是可以找到适合当前eclipse或者myeclipse版本的egit插件,但是不好的是使用这种方式可能由于网络被墙的原因导致安装不上,而且不管好管理自己已经安装的插件。不推荐使用。

第二种方式:

1、查看自己所有的eclipse或者myeclipse基于的eclipse版本

对于eclipse:

\
\

对于myeclipse,我使用的是myeclipse10.7

\

打开如下图的窗口。

\

但是上图中看不出myeclipse基于的eclipse版本,可以点击installtion Details 按钮,如下所示:

\

由上图可知基于的eclipse版本是3.7.2.

其次是去egit官网上下载对应eclipse版本的egit插件。

egit下载地址:https://www.eclipse.org/egit/download/

通过以下网址找到3.7.2版本的eclipse应该下载哪个版本的egit:https://wiki.eclipse.org/EGit/FAQ#What_versions_of_Eclipse_does_EGit_target.3F,如下截图所示,找到eclipse对应的egit版本。

\
\

然后到:https://wiki.eclipse.org/EGit/FAQ#Where_can_I_find_older_releases_of_EGit.3F,下载zip包,我需要下载的是2.2.0版本的。点击列表中最后一栏download p2 repository的连接,下载离线版的egit插件。

2、找到myeclipse安装目录下的dropins文件夹,然后新建egit文件夹,将下载egit压缩文件解压放到egit文件夹下:

\

4、重启eclipse或者myeclipse。

5、window->preferences->Team->git

\

第三种方式:

这种方式和第二种方式的区别在于放置egit文件的位置不同。

在dropins文件夹下通过新建一个*.link文件,然后文件中输入PATH=egit的路径,这样的方式,可以不用担心以后插件过多时出现混乱,也方便移除相关插件。具体内容如下图中所示:

\

其中link文件的内容是path=egit的路径。

第三种方式是最为推荐的,方便添加和移除eclipse插件,不至于插件过多导致的管理混乱,同时也有利于eclipse的优化,如果某个插件不想用了可以直接移除掉,加速eclipse 的启动。

相关文章
最新文章
热点推荐