首页 > 程序开发 > 移动开发 > Android >

使用Android Studio运行项目出现 UnsupportedMethodException 错误的解决办法

2017-04-28

从GitHub上线下载了项目,运行时候报错如下经过试了网上提供的这种方法么有成功,然后只能升级对应的build-tools工具。

从GitHub上线下载了项目,运行时候报错如下

\

经过试了网上提供的这种方法

\

么有成功,然后只能升级对应的build-tools工具

\

而且大家在项目的build.gradle中的

dependencies {
    classpath 'com.android.tools.build:gradle:2.2.2'

    // NOTE: Do not place your application dependencies here; they belong
    // in the individual module build.gradle files
}
gradle版本也是和app中对应的gradle版本相对应得,比如我这里是gradle2.2.2,所以我在app对应的gradle文件夹下gradle-wrapper.properties中
distributionUrl=https\://services.gradle.org/distributions/gradle-2.14.1-all.zip
一定不要随便改,两者有对应的关系,按照提示修改。
相关文章
最新文章
热点推荐