首页 > 网络 > 交换机 >

cisco 交换机和cisco2901路由器 划分VLAN上网的实例教程

2018-07-24

cisco 交换机和cisco2901路由器 划分VLAN上网的实例教程。VLAN划分如下:

VLAN划分如下:

vlan ip段 子网掩码 DNS服务器 网关 端口
vlan20 192.168.2.0 255.255.255.0 192.168.1.1(路由器上配置了DNS服务器,见上一篇博客) 192.168.2.1 gi4-6
vlan30 192.168.3.0 255.255.255.0 192.168.1.1 192.168.3.1 gi7-9
vlan40 192.168.4.0 255.255.255.0 192.168.1.1 192.168.4.1

gi10-12

交换机配置

1、划分VLAN,指定网关,ip范围

vlan database
vlan 20
vlan 30
vlan 40

interface vlan20 
ip address 192.168.2.1  255.255.255.0
exit

interface vlan30 
ip address 192.168.3.1  255.255.255.0
exit

interface vlan40 
ip address 192.168.4.1  255.255.255.0
exit

2、指定物理端口范围,并加入到对应Vlan


interface range gi4-6
switchport mode access 
switchport access vlan 20
exit

interface range gi7-9
switchport mode access 
switchport access vlan 30
exit

interface range gi10-12
switchport mode access 
switchport access vlan 40
exit

3、交换机默认的vlan1 添加网关,用于连接路由器

gi4-12端口已经分配出去,剩下的端口在交换机上默认归属vlan1,用于连接路由器的端口可从剩下的端口中随便选取一个即可。


interface vlan 1
ip address 192.168.1.2 255.255.255.0
exit

4、配置DHCP服务器,用于动态分配IP

5、添加一条默认路由规则,指向路由器内网端口IP


conf t
ip route 0.0.0.0 0.0.0.0 192.168.1.1
exit

路由器配置

1、修改访问列表


//取消原来的列表,原来只允许192.168.1.0的网段访问外网,现在需要192.168.2.0,192.168.3.0,192.168.4.0都能访问外网

no access-list 10 permit 192.168.1.0 0.0.0.255 
access-list 10 permit 192.168.0.0 0.0.255.255

2、设置回程路由


ip route 192.168.2.0 255.255.255.0 192.168.1.2
ip route 192.168.3.0 255.255.255.0 192.168.1.2
ip route 192.168.4.0 255.255.255.0 192.168.1.2

上述配置完成后,用网线将路由器的192.168.1.1端口与交换机上vlan1中的任意端口连接起来,即可上网。

相关文章
最新文章
热点推荐